Autor Wątek: Klient PPTP działa ?  (Przeczytany 3765 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline krzychoo

  • Nowy użytkownik
  • *
  • Wiadomości: 1
    • Zobacz profil
Klient PPTP działa ?
« dnia: Luty 09, 2014, 12:19:42 »
Witam.
Analogicznie jak w windzie - tutaj na Puppy Slacko 5.6 wykorzystując  Gpptp  wpisuję niezbędne dane :adres, login, hasło ,           
i  w okienku dialogowym mam po chwili komunikat  :

"Connecting to VPN server...
pptp process (21106) exited with 0

   VPN ppp0 - (pid  21200) created ... "

No i lipa. Wbrew ostatniemu stwierdzeniu (created)   tunelu brak.

Pewnie robię coś źle. (Nie jestem linuksiarzem !  - choć co nieco kumam)

Testuję na serwerze  free bestukvpn  oraz na własnym na routerze.  Winda tuneluje w mig na obydwóch.

Gdzie robię błąd ?


« Ostatnia zmiana: Luty 09, 2014, 13:18:10 wysłana przez krzychoo »

Offline robwoj44

  • Aktywny użytkownik
  • ***
  • Wiadomości: 110
    • Zobacz profil
    • Email
Odp: Klient PPTP działa ?
« Odpowiedź #1 dnia: Luty 12, 2014, 06:09:13 »
Powinno to wyglądać tak:
1. w /etc/ppp kopiujemy plik "ip-up-EXAMPLE" i zmieniamy na "ip-up"
2. w pliku /etc/ppp/options.pptp, odkomentowujemy linię "require-mppe-128", a dodajemy # przed "refuse-chap" i zapisujemy plik.
3. Startujemy gpptp
4. Naciskamy "connect" i czekamy na "VPN pppX - (pid XXXXXX) created..."
5. Wpisujemy w konsoli "ip route add default dev ppp0"
5a. Jeśli są dwa połączenia ppp (gdy ppp1 to vpn) - np w przypadku połączenia poprzez modem to wówczas:
route add -host bestukvpn.com dev ppp0
route del default ppp0
route add default dev ppp1
« Ostatnia zmiana: Luty 27, 2014, 18:53:19 wysłana przez robwoj44 »