Autor Wątek: Jak zainstalować grę ? Puppy Slacko 5.4  (Przeczytany 5955 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Laadder

  • Nowy użytkownik
  • *
  • Wiadomości: 21
    • Zobacz profil
Jak zainstalować grę ? Puppy Slacko 5.4
« dnia: Kwiecień 28, 2013, 10:59:59 »
Modyfikuje wątek bo nie chce zakładać nowego tematu. Co do poprzedniej gry to jednak za trudne dla mnie:)
Chciałbym odpalić grę TORCS: oficjalna storna http://torcs.sourceforge.net/
Grę z rozszerzeniem *.run pobieram z tej strony http://www.portablelinuxgames.org/
Zaptaszyłęm opcję "wykonanie" ale gra nie chce ruszyć. Pomocy:)
« Ostatnia zmiana: Maj 30, 2013, 22:53:27 wysłana przez Laadder »

Offline witek_w11

  • Zaawansowany użytkownik
  • ****
  • Wiadomości: 398
    • Zobacz profil
Odp: Jak zainstalować grę ? Puppy Precise 5.5
« Odpowiedź #1 dnia: Kwiecień 28, 2013, 20:20:20 »
Witam.
Jeżeli chcesz dociągnąć brakujące elementy to najpierw szukasz ich w repozytoriach. Na pulpicie masz ikonę 'instaluj', kliknij ją, następnie kliknij małą ikonkę obok napisu 'Puppy Manager Pakietów'. Teraz musisz zaptaszyć opcję 'dev' bo pakiety które szukasz są tego typu oraz odptaszyć zaptaszoną domyślnie opcję wykonywalną czyli 'exe'. Nazwy szukanych pakietów masz wypisane w sekwencji:
Installing the required libraries on Ubuntu -
sudo apt-get
Twoim zadaniem jest po kolei wpisywać je do linijki dialogowej:
libsdl
libdsl-ttf
libdsl-mixer
libdsl-image
libmysqlclient
libwxgtk2.8
za każdym razem klikasz 'idź', wybierasz opcję przeszukania wszystkich dostępnych repozytoriów, po prawej wyskakują Ci szukane pakiety, klikasz je i ściągasz. Jak wyskoczy więcej niż jeden ściągasz ten najbardziej pasujący, najczęściej z samej góry.
.
Ale jest jeszcze taka sprawa że najwyraźniej zabrałęś się nie za instalowanie gry tylko za jaj kompilację. Zapewne pobrałeś pakiet źródłowy i teraz dopiero przystępujesz do budowania tej gry. Mówię o tym bo nie wiem czy taki był Twój cel. Żeby kompilować musisz jeszcze dołączyć kompilator, dla Precise5.5 dostępny jest tutaj.
http://distro.ibiblio.org/quirky/precise-5.5/devx_precise_5.5.sfs
Ale może nie warto kompilować (bo łatwo się zniechęcić), może lepiej poszukać tej gry dla Ubuntu czyli systemu bazowego dla Precise.
Pozdrawiam.
« Ostatnia zmiana: Kwiecień 28, 2013, 20:23:13 wysłana przez witek_w11 »

Offline Laadder

  • Nowy użytkownik
  • *
  • Wiadomości: 21
    • Zobacz profil
Odp: Jak zainstalować grę ? Puppy Precise 5.5
« Odpowiedź #2 dnia: Kwiecień 29, 2013, 22:45:08 »
Wielkie dzięki. Chyba masz racje zabrałem się za coś trudnego:)

Offline witek_w11

  • Zaawansowany użytkownik
  • ****
  • Wiadomości: 398
    • Zobacz profil
Odp: Jak zainstalować grę ? Puppy Precise 5.5
« Odpowiedź #3 dnia: Kwiecień 30, 2013, 04:54:47 »
Ściągnąłem tą grę stąd:
http://heanet.dl.sourceforge.net/project/zod/linux_releases/zod_linux-2011-09-06.tar.gz
i po rozpakowaniu okazało się że można próbować uruchomić ją bez kompilacji. Udało mi się ale w nie do końca prawidłowy sposób. Doinstalowałem następujące pakiety:
libsdl-image1.2
libsdl-mixer1.2
libmikmod2
oss-compat
libsdl-ttf
libwxgtk2.8
libgstreamer0.10-0
libgstreamer-plugin-base
iso-codes
libwxbase2.8
oczywiście są to pakiety wykonywalne nie budowlane czyli 'exe'. I teraz zaczęły się schody gdyż nie mogłem uruchomić gry z pakietem libmysqlclient18 który jest dostępny w repo Ubuntu12, gra ciągle żądała wcześniejszej wersji libmysqlclient16, której w nowych repozytoriach już nie ma. Znalazłem taki pakiet tutaj:
http://launchpadlibrarian.net/75949497/libmysqlclient16_5.1.58-1ubuntu1_i386.deb
ale nie wiem na ile Debian jest kompatybilny w dół, moja wiedza niestety jest niewielka. W każdym razie po zainstalowaniu tych wszystkich pakietów grę uruchamiamy poprzez kliknięcie pliku 'zod_launcher'. Jeżeli system ma Ci służyć tylko do gier możesz spróbować ale jeżeli do czegoś poważniejszego to raczej nie ryzykuj. Myślę że bardziej prawidłowa będzie kompilacja, spróbuję później pokombinować ale nie obiecuję że dam radę.